MMS Delivery Delays
Incident Report for Dialpad
Resolved
We continue to work with our US carriers about this issue but no longer are seeing MMS delays.
Posted Apr 21, 2020 - 13:45 PDT
Investigating
We are currently experiencing significant delays receiving MMS messages for one of our US carriers.
Posted Apr 21, 2020 - 09:04 PDT
This incident affected: Carrier Networks: Messaging.