Network Outage affecting users in Mexico
Incident Report for Dialpad
Resolved
Issue was resolved and all affected numbers were operational again as of 5:53PM PST. Partial outage lasted less than 10 min
Posted almost 2 years ago. Feb 09, 2017 - 08:11 PST
Investigating
Our local provider in Mexico is experiencing a network outage. This is affecting some of our users in the country. We'll update this page as soon as we know more.
Posted almost 2 years ago. Feb 08, 2017 - 18:03 PST