Issue with inbound toll-free call routing
Incident Report for Dialpad
Resolved
This incident appears to have been resolved for the majority of customer calls as of Mar 25th 12:30pm PDT (19:30 UTC).
Posted Mar 25, 2024 - 15:07 PDT
Update
We are continuing to monitor for any further issues.
Posted Mar 25, 2024 - 13:15 PDT
Monitoring
We have identified a problem with upstream aggregator of toll-free traffic that was mis-routing calls. Dialpad has made a change to re-route our traffic around that aggregator. We expect that inbound toll-free call will complete normally for all customers shortly but there may be some delay as other carriers need to detect and react to the changes.
Posted Mar 25, 2024 - 11:45 PDT
Update
We are continuing to investigate this issue.
Posted Mar 25, 2024 - 11:11 PDT
Investigating
We're currently investigating an issue causing inbound calls to be misrouted and are not reaching some main department numbers
Posted Mar 25, 2024 - 11:06 PDT
This incident affected: Telephony Infrastructure: Inbound Calls, Carrier Networks: Local Numbers, and Carrier Networks: Toll-Free Numbers.