Issues accessing the Contact Support page
Incident Report for Dialpad
Resolved
This incident has been resolved.
Posted Jul 12, 2022 - 11:28 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 12, 2022 - 11:24 PDT
Update
We are still in the process of implementing the fix. Users can continue to contact us directly by emailing Support@dialpad.com
Posted Jul 12, 2022 - 11:15 PDT
Update
The fix is still being implemented for this issue. Users can continue to contact us directly by emailing Support@dialpad.com
Posted Jul 12, 2022 - 10:31 PDT
Identified
The issue has been identified and a fix is being implemented. Users are able to contact us directly by emailing Support@dialpad.com
Posted Jul 12, 2022 - 10:01 PDT
Investigating
The Dialpad "Contact Us" page (https://dialpad.com/contact-support) is currently not loading and gives a 500 error. We are actively investigating. You are able to contact Dialpad Support by directly emailing Support@dialpad.com
Posted Jul 12, 2022 - 09:34 PDT
This incident affected: Website.