Third party Salesmate integration inadvertently deleting users
Incident Report for Dialpad
Resolved
Dialpad has disabled all the API keys we believe to associated with the Salesmate integration and restored the users it deleted. If you use Salesmate's integration, please connect with their support directly on when a fix will be available. When you are ready to re-enable the integration, please create a new API key for it. If required, you can contact Dialpad support to re-enable the existing API key.
Posted Feb 21, 2024 - 17:25 PST
Update
We are continuing to work on a fix for this issue.
Posted Feb 21, 2024 - 16:07 PST
Identified
We have identified the issue and found the list of API keys with Salesmate and disabled it.
Posted Feb 21, 2024 - 13:57 PST
Update
We are continuing to investigate this issue.
Posted Feb 21, 2024 - 12:36 PST
Update
We believe there is an issue where a third party Salesmate integration may be unintentionally deleting Dialpad users through the API. Dialpad is attempting to reach out to this external company / developer. It is not clear yet, what triggers the deletion. If possible, we recommend disabling this integration.
Posted Feb 21, 2024 - 11:15 PST
Update
We are investigating reports of some users being deactivated unintentionally through the API. We are currently investigating this issue.
Posted Feb 21, 2024 - 10:48 PST
Investigating
We are currently investigating this issue.
Posted Feb 21, 2024 - 10:34 PST
This incident affected: Integrations.