Increased datastore latency and timeouts causing sporadic failures

Incident Report for Dialpad

Resolved

The incident appears to be over. Datastore latencies have remained at normal levels.
Posted Oct 06, 2024 - 23:54 PDT

Monitoring

Google has identified and resolved the issue. We have seen database latency return to normal. We are awaiting more details on the root cause and will continue monitoring database performance.
Posted Oct 06, 2024 - 23:05 PDT

Update

We are continuing to investigate this issue.
Posted Oct 06, 2024 - 22:15 PDT

Update

Dialpad is actively assisting Google Cloud Platform with their investigation into the increased latencies and timeouts. The error rate remains low (0.3%) but elevated enough that customers may see sporadic issues with any number of actions or events.
Posted Oct 06, 2024 - 20:04 PDT

Investigating

We are currently investigating the issue.
Posted Oct 06, 2024 - 18:54 PDT
This incident affected: Google Cloud Platform.