Investigating an issue affecting calls in Japan
Incident Report for Dialpad
Resolved
All calls in Japan are working normally.
Posted over 1 year ago. Apr 21, 2017 - 18:27 PDT
Investigating
We are currently investigating this issue.
Posted over 1 year ago. Apr 21, 2017 - 18:24 PDT