Dialpad Meetings SMS Notifications are Undeliverable for some customers
Incident Report for Dialpad
Resolved
As of December 9th, 2024 at 11 AM PST notification services are restored.
Posted Dec 10, 2024 - 06:28 PST
Identified
Our team continues to investigate the issue. In the meantime, users can configure email notifications while we continue to work on a fix for text notifications.

https://help.dialpad.com/docs/adjust-your-dialpad-meetings-notifications
Posted Nov 20, 2024 - 11:03 PST
Investigating
We are investigating an issue with SMS notifications being blocked for Dialpad meetings. More details will be provided shortly.
Posted Nov 20, 2024 - 10:37 PST
This incident affected: Meetings.